Issue
If a message you sent is not delivered to the end device and returns a 30004 error code, this means that delivery of your message failed because the destination is blocked from receiving this message.
Product
Programmable Messaging
Cause
If the message has the "undelivered" status, this means that delivery of your message failed after Twilio sent the message to the carrier.
Possible causes of error 30004 on "undelivered" messages include:
- The user is registered on a "Do Not Disturb" or "Do Not Call" list that blocks SMS from unknown senders.
- The user is not able to receive your SMS due to specific configuration or limitations of their mobile phone service plan
- The receiving carrier has blocked the message for violating their rules or policies. For related information, see the information for troubleshooting error 30007.
Resolution
Possible solutions for error 30004 on "undelivered" messages include:
- Check the Twilio Status Page to see if an active incident could be causing your issues.
- Check Twilio’s SMS Guidelines for the country you are sending messages to. Twilio keeps these pages up to date with best practices for each country. Ensure you are following these best practices with your messages.
- If you are sending application-to-person (A2P) SMS to a country where Alphanumeric Sender ID pre-registration is available, such as Saudi Arabia or Malaysia, sending messages without pre-registering may result in error 30004. Please see International Support for Alphanumeric Sender ID for a full list of countries and more information.
If you can rule out all of the above issues, continue troubleshooting below.
"Failed" Messages
Messages with a "failed" status and error 30004 may indicate that Twilio is blocking those messages due to suspected unwanted or malicious message contents. Twilio has anti-spam protections in place to help protect end users from unwanted messaging.
If you are seeing messages with "failed" status (as opposed to "undelivered") and you believe your messages are being blocked in error, please contact Twilio support with example Message SIDs from your SMS logs and an explanation of your use case.
Continued Error 30004 Issues
Twilio's Support team can help investigate what went wrong with delivering your message. Please collect 3 or more Message SIDs in your SMS logs from the last 24 hours that were flagged with Error 30004, and open a support request.