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IP not allowed error in Segment warehouse Syncs

Issue

Warehouse syncs start failing with IP not allowed error.

 

Product

Twilio Segment

 

Environment

Segment Console

 

Cause

From July 1st, 2026, Segment started upgrading its warehouse infrastructure to significantly improve reliability and high availability. Moving forward, warehouse syncs will route through a new, multi-zone infrastructure.

Because of this change, Segment will be using new IP addresses to connect to your destination. If your firewall is not updated, it will block these new connections, causing your warehouse syncs to fail.

 

Resolution

Please pass this information along to your Network Engineering, DevOps, or IT Security team. They will need to add the following two IP ranges to your warehouse firewall allowlist:

New IP Addresses to Add:

 

Additional Information 

Warehouse specific documentation:

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