Issue
If you have set up Salesforce Service Cloud Voice (SCV) and enabled the Dialpad but are seeing a 45600 error referring to "Action is pending" when attempting to make outbound calls in Salesforce, you may need to adjust your Task Queue configuration and ensure consistent naming between Salesforce and TaskRouter.
Product
Flex
Cause
This error can be the result of a Task Queue not having a Reservation Activity or Assignment Activity.
You will also want to make sure that your Salesforce Presence Status name exactly matches your TaskRouter Activity name.
Resolution
Ensure that your Task Queue has an AssignmentActivitySid and ReservationActivitySid set, and that your Salesforce Presence Status matches your TaskRouter Activity.