SUPPORT.TWILIO.COM END OF LIFE NOTICE: This site, support.twilio.com, is scheduled to go End of Life on February 27, 2024. All Twilio Support content has been migrated to help.twilio.com, where you can continue to find helpful Support articles, API docs, and Twilio blog content, and escalate your issues to our Support team. We encourage you to update your bookmarks and begin using the new site today for all your Twilio Support needs.

Fix Google Ads Remarketing Forbidden Error in Segment

Issue

When attempting to add the Google Ads Remarketing Lists destination in a Segment Audience, you may encounter the error: "Forbidden. The caller does not have permission". This prevents the audience sync.

 

Product

Twilio Segment

 

Environment

Segment Console

 

Cause

This error occurs when the Google Ads account linked to the integration has been deleted or the authentication token is no longer valid, resulting in an invalid_grant error.

 

Resolution

To resolve this issue, follow these steps:
  1. Verify that the Google Ads account connected to the integration is active.
  2. Reauthorize the Google Ads integration in Segment to generate a new, valid refresh token.
  3. Retry adding the destination after reauthorization.

 

Have more questions? Submit a request
Powered by Zendesk