SUPPORT.TWILIO.COM END OF LIFE NOTICE: This site, support.twilio.com, is scheduled to go End of Life on February 27, 2024. All Twilio Support content has been migrated to help.twilio.com, where you can continue to find helpful Support articles, API docs, and Twilio blog content, and escalate your issues to our Support team. We encourage you to update your bookmarks and begin using the new site today for all your Twilio Support needs.

Source Events Missing from Segment Audience Builder UI

Issue

You are unable to see events from a specific source in the Segment audience builder, even though the source is successfully connected and listed in your workspace. Expected events from that source do not appear as selectable options when you attempt to create a new audience.

 

Product

Twilio Segment

 

Environment

Segment Console

 

Cause

The connected source has not been explicitly added as a profile source within your Unify space. Segment requires sources to be authorized as profile sources before their event data can be ingested and utilized by the audience builder.

 

Resolution

To resolve this issue and make the events visible, add the source to your Unify space by following these steps:

  1. Log in to your Segment workspace.

  2. Navigate to your Unify space settings.

  3. Locate the profile sources configuration section.

  4. Select and add the missing source to your profile sources.

  5. Return to the audience builder to verify that the source events are now visible and selectable.

 

Additional Information

Instances of the desired event will need to be present in the source schema in order to be present in the Audience Builder UI. 

Have more questions? Submit a request
Powered by Zendesk