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Getting error No AudienceId returned when connecting Microsoft Bing Ads audiences to an audience

 

Issue

I am trying to connect my Microsoft Bing Ads Audiences destination to an Engage audience and I get error "Failed to create the external audience: Failed to create audience: No AudienceId returned"

 

Product

Twilio Segment

 

Environment

Segment Console

 

Cause

Whenever you connect an audience to an audience destination such as Microsoft Bing Ads Audiences Destination, Engage will trigger the downstream audience/list creation flow, which should result in the list being created downstream. If this process fails, Engage will throw an error indicating that the audience was not created downstream.

 

Resolution

If you are getting error “Failed to create the external audience: Failed to create audience: No AudienceId returned” when linking the destination to the audience, make sure that that account has the necessary permissions/access, and that the Customer Account ID and Customer ID are set correctly. If the issue persist, re-authenticate the account in the destination settings and check if there is already an existing audience in Microsoft Bing Ads with the same name.

 

Additional Information 

I get error “400: The root value is missing the required field ‘audience_id’ when sending test records

This error is expected when sending test events. expected. When you connect this destination to an audience, Engage will trigger the downstream audience creation flow. If everything goes well, the destination should create the list in their platform and respond with an AudienceId. Engage will then store this identifier and use it to sync users as needed. This context will be stored internally and added automatically to payloads. Unfortunately, because of this, you will not be able to send test payloads via the mapping tester or the event tester, since those payloads will lack the required AudienceId that Engage automatically populates when generating payloads.

Should I use track or identify calls to sync to the destination?

In theory, you could use either identify or track calls with the Sync Audiences mapping. You would just need to make sure that the relevant fields are mapped accordingly. For example. if using email as an identifier, you would need to either select the field from the traits object for identify calls, or properties for track. Alternatively, you could use the coalesce function to capture it from the one present in the payload.

Do I need separate mappings for audience entered and exited events?

No. You do not need to have 2 distinct mappings for audience entered/exited. You can have a single mapping to be triggered just with track calls. Audience Entered and Exited events are handled internally.

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