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Unify Filters Not Working for Newly Added Sources in Segment

Issue

When using Unify filters in Segment, customers may notice that events from newly added sources are not being filtered as expected. Even after updating filter criteria to exclude specific source IDs, events from new sources can still appear in tables such as identifies. This issue is commonly reported when customers add a new source to their Unify space and expect filters to apply immediately.

 

Product

Twilio Segment 

 

Environment

Segment Console

 

Cause

Unify filters (beta) require each new source to be explicitly enabled by Segment support before filters will apply. If a new source is added to a Unify space but not registered on the backend, events from that source may bypass the defined filters. This is a current limitation of the beta feature.

 

Resolution

To ensure Unify filters apply to all intended sources:

  1. After adding a new source to your Unify space, provide the source name(s) or ID(s) to Segment Support.
  2. Segment Support will enable the new source(s) for filtering on the backend 
  3. Repeat this process for each additional source you add that should be subject to Unify filters.

 

Additional Information 

  • The Unify filters beta currently supports only dropping events. Filtering on allow_properties and drop_properties is not supported.
  • If you need to delete user profiles from Unify, this must be done at the workspace level using Segment’s GDPR User Deletion and Suppression tools.
  • Always notify support when adding new sources that require filtering to avoid unfiltered data.
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