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CSV-uploaded traits may not immediately appear in Audience Builder

Issue

After uploading traits via CSV using the "Add Profiles" feature in Segment Profile Explorer, users may not see trait elements immediately in the Audience Builder or may be unsure how to remove previously uploaded traits.

 

Product

Twilio Segment

 

Environment

Segment Console

 

Cause

Trait values uploaded via CSV are written directly to user profiles. Trait keys appear immediately if the upload is successful, but trait values do not auto-populate in the Audience Builder and must be entered manually. Uploaded CSV files cannot be deleted, and traits remain unless overwritten.

 

Resolution

Trait keys should appear in the audience builder immediately after a successful CSV upload.

  • To view user profiles by trait value in the Audience Builder, manually enter or paste the desired value.
  • To remove a trait from user profiles, upload a new CSV with the same user identifiers and leave the trait column blank or set to "null" for each user. This will overwrite and remove the trait from those profiles.

 

Additional Information 

Uploaded CSV files are only visible to the uploader and Workspace Owners. Other workspace users cannot access these files.

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