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Inbound SMS Failures After Porting Due to Stale RCS Registration

Issue

Inbound SMS or MMS messages fail to reach Twilio after a phone number is ported to Twilio. This happens because the Twilio number is identified as RCS capable due to a stale RCS registration. Instead of delivering a standard SMS, the iOS or Android device attempts to send an RCS message to the Twilio number which fails and does not fall back to SMS, preventing the message from ever reaching the Twilio platform.

Products

Twilio Programmable Messaging (SMS/MMS)

Porting

Cause

When a consumer mobile number is ported to Twilio, its previous registration in the RCS ecosystem may remain active. The global registry still flags the number as RCS enabled. Carriers only allow Twilio to receive RCS messages on registered RCS senders, not phone numbers, ultimately leading to a silent delivery failure.

Prevention

Before porting, make sure to disable RCS on the phone number being ported using the steps described below. If this wasn't completed, then after porting the phone number, you may use the Google RCS De-registration Web Tool.

If the web tool fails or the registration persists after 72 hours, contact the losing carrier (the provider the number was ported from) and request that they manually remove the number from their RCS/MaaP registry. Ultimately, Google typically removes stale P2P RCS registrations automatically after 31 days of inactivity, but manual intervention is required for an immediate fix.

Resolution

If the phone number(s) has been ported-in to Twilio already, the stale RCS registration must be deactivated at the ecosystem level. Follow these steps:

  • Option A: Manual De-registration (Android/iOS/Universal) 
    Use the Google RCS De-registration Web Tool.
    • Enter the phone number.
    • Enter the 6-digit verification code sent to the device.
    • Note: It can take 24-72 hours for this change to propagate across all global carriers.

       
  • Option B: On-Device Deactivation (iOS) 
    If the number is still associated with an iPhone, the user must manually toggle the setting:
    • Open Settings > Apps > Messages.
    • Under the Text Messaging section, select RCS Messaging.
    • Toggle RCS Messaging to OFF.

       
  • Option C: On-Device Deactivation (Android)
    • Open Google Messages > Tap on your avatar > Setting > RCS chats
    • Toggle RCS Messaging to OFF
       

Additional Information

  • No Impact on Outbound: This issue only affects inbound messages sent from consumers to Twilio; outbound SMS/MMS from Twilio to consumers is unaffected.

Pre-Porting Best Practice: To prevent inbound message failures, it is highly recommended that customers disable RCS messaging on the device before initiating the port to Twilio. Disabling the feature allows the device to send a "de-registration" signal to the carrier and Google Jibe, which is significantly more reliable than attempting to de-register the number after the port is complete.

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