Issue
Warehouse syncs failing or partially failing with an error that says 'tables can have at most 1600 columns'.
Product
Twilio Segment
Environment
Segment Console
Cause
This usually means you've reached Redshift's limit of 1600 columns per table.
Resolution
In order to get this fixed, you'll have to:
- Identify what the affected table is, and why the number of columns within that table has gone over the 1600 limit.
- This usually happens as a consequence of columns being dynamically generated due to a bug in your implementation code.
- Ensure that root cause has been addressed and stopped. E.g., bug has been fixed.
- Reach out to Twilio Segment Support so the erroneous columns can be disabled internally.
- Once that's done, drop these columns from your own warehouse, to allow syncs to resume.