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Task Transfer Failure Reasons

Issue

When attempting to transfer a Task to another agent, a Flex Worker is unable to do so and the call drops unexpectedly.

 

Product

Twilio Flex

 

Cause

There can be many reasons why a Task transfer between Flex agents may fail. Here are a few reasons:

  1. The Worker who receives the corresponding reservation of a Task transfer rejects the reservation.
  2. The Task Time to Live (TTL) is reached.
  3. The Task was wrapped or completed while a warm transfer was in progress.

 

Resolution

To address the aforementioned task transfer failure reasons, it is important to ensure that agents are available to accept the Task transfer once the Task is placed into the target TaskQueue. It is also critical that a warm transfer is accepted before the Task is wrapped or completed, and before the TTL expires.

 

Additional Information 

Information about how to manage Task timeouts during active calls in Flex can be found at the following links:

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