SUPPORT.TWILIO.COM END OF LIFE NOTICE: This site, support.twilio.com, is scheduled to go End of Life on February 27, 2024. All Twilio Support content has been migrated to help.twilio.com, where you can continue to find helpful Support articles, API docs, and Twilio blog content, and escalate your issues to our Support team. We encourage you to update your bookmarks and begin using the new site today for all your Twilio Support needs.

Diagnosing Stuck Tasks in the Flex UI

Issue

In rare situations, Flex Tasks can remain in the Flex UI (such as on the Teams View page) even though the underlying TaskRouter Task has already completed, canceled, or been deleted.

Product

Flex UI

Cause

During outages or unusual conditions, data between TaskRouter and the Flex UI may become out of sync. As a result, the Flex UI may continue to display a Task that no longer exists in TaskRouter, even though the backend data is accurate.

Impact

You may see a "stuck" Task in the Flex UI. To determine where the issue exists, use the following check:

Check Task Status with TaskRouter API

Run the following cURL command (replace the SIDs with your own values):

curl -X GET "https://taskrouter.twilio.com/v1/Workspaces/WSaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa/Tasks/WTaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" \
-u $TWILIO_ACCOUNT_SID:$TWILIO_AUTH_TOKEN

Outcome:

  • If you receive a 404 response:
    • Double-check that your Task SID is correct. If it is, and you get a 404, the Task has already been closed for over 5 minutes. This means the Task isn't stuck in TaskRouter.
  • If the Task is returned and assignment_status is terminal (e.g., 'completed', 'canceled', or 'wrapping'):
    • The Task has ended correctly. It is not stuck in TaskRouter.
  • In both of these cases, the issue is only in the Flex UI. This is a visual defect and does not negatively impact reporting or backend operations.

If the Task appears "stuck" within TaskRouter (not in a terminal state or still returned by the API), please refer to these instructions for further troubleshooting.

Resolution

If a Task is only stuck in the Flex UI (but not in TaskRouter), please contact Twilio Support for assistance clearing the Task from your interface.

If possible, include the Task SID (WTxxxxxxxxxxxx) of the impacted resource.

Additional Information

Have more questions? Submit a request
Powered by Zendesk