Issue
TaskRouter Tasks are canceled immediately with canceled reason "queue-full". Voice calls associated to the canceled Task are dropped.
Product
TaskRouter, Programmable Voice
Cause
The Programmable Voice Queue associated with the TaskRouter Workflow is full.
When the Voice Queue reaches its MaxSize, new calls cannot be enqueued, and the corresponding Task is canceled with reason queue-full.
| MaxSize | The maximum number of calls allowed to be in the queue. The default is 1000. The maximum is 5000. |
Resolution
In order to resolve this issue, increase the MaxSize property on the Voice Queue resource. The Voice Queue can be updated via the API or helper library.
curl -X POST "https://api.twilio.com/2010-04-01/Accounts/ACxxxxxxx/Queues/QUxxxxxxx.json" \
--data-urlencode "MaxSize=1000" \
-u ACxxxxxxx:your_auth_token