SUPPORT.TWILIO.COM END OF LIFE NOTICE: This site, support.twilio.com, is scheduled to go End of Life on February 27, 2024. All Twilio Support content has been migrated to help.twilio.com, where you can continue to find helpful Support articles, API docs, and Twilio blog content, and escalate your issues to our Support team. We encourage you to update your bookmarks and begin using the new site today for all your Twilio Support needs.

Flex User Interface in an Iframe - Chat Disappearing and Requiring Page Refresh

Issue

An agent opens an active conversation, the conversation panel appears completely blank (white screen), and the conversation history is not displayed. The interface only returns to normal after the agent refreshes the Flex page.

Product

Flex

Cause

This typically indicates the Conversation panel is not refreshed properly due to a caching problem of the iframe component.

Resolution

Force a refresh of the iframe component upon initial page load

Additional Information 

Toggle the Disable cache checkbox in Developer Tools in the browser to troubleshoot the issue. Review the outgoing traffic in the browser ( in Chrome: Dev Tools > Network tab) to make sure there are no blocked requests

Have more questions? Submit a request
Powered by Zendesk