SUPPORT.TWILIO.COM END OF LIFE NOTICE: This site, support.twilio.com, is scheduled to go End of Life on February 27, 2024. All Twilio Support content has been migrated to help.twilio.com, where you can continue to find helpful Support articles, API docs, and Twilio blog content, and escalate your issues to our Support team. We encourage you to update your bookmarks and begin using the new site today for all your Twilio Support needs.

Inbound Messages Failing to Execute a Studio Flow

Issue

Inbound Messages fail to execute a Studio Flow (as per normal Messaging Orchestration).

 

Product

Twilio Flex 

 

Cause

In production, tasks are typically accepted and completed by workers within the expected time-to-live (TTL) window. This ensures that tasks progress smoothly to completion and associated Conversations are properly closed.

When running tests, it’s common to create test tasks but forget to complete them, either in the UI or via API. If these tasks are left incomplete, they will eventually reach their TTL and be system-deleted. When this happens, the orchestration cannot close the associated Conversation.
 
As a result, if a new inbound message arrives, it will not trigger the Studio Flow configured in a Conversation Address. Instead, the message is added to the still-active channel (which should not be active, since there’s no agent assigned), preventing the Studio Flow from executing and blocking the creation of new tasks.

 

Resolution

When testing, always ensure you manually close or complete your test tasks in the UI (or via API) to avoid these issues. If needed, close or delete the task via API.

While rare, similar issues can occur in production if a worker accepts a task but fails to complete it before the TTL expires. This also leads to system deletion and the same orchestration problem.

Have more questions? Submit a request
Powered by Zendesk