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Not Receiving Incoming SMS and MMS Messages on Twilio Phone Number

Issue

Inbound SMS and MMS messages not reaching Twilio number as expected.

 

Product

Programmable Messaging

 

Cause

There are several causes for not receiving inbound SMS and MMS Messages. Below are several resolutions that can narrow down the cause of the issue.

 

Resolution

Check for SMS-enabled Twilio number with a valid configuration

  1. Log into your Twilio project at www.twilio.com/console.
  2. Click Phone Numbers from the left-side navigation bar.
    NOTE: If Phone Numbers is not visible, you may first need to click All Products & Services.
  3. Check that your Twilio number has the SMS icon listed under "Capabilities". If your Twilio phone number does not have SMS capabilities, you will need to buy an SMS capable phone number to receive incoming SMS messages.
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  4. Click your number, and verify that you have a valid configuration for receiving messages.

Check if the  SMS message was sent from an international number (a different country than your Twilio number)

Twilio promises support for receiving SMS within the same country as your Twilio SMS-enabled number. For example, a German mobile number can deliver SMS to a German Twilio mobile number. If you ever encounter delivery issues on in-country incoming SMS, please contact Twilio Support.

For non-domestic incoming SMS, some international carriers are unable to successfully pass off SMS into Twilio’s network. Because of this, Twilio cannot guarantee that incoming messages will be received. For example, a German mobile number may not be able to deliver SMS to a UK Twilio number.

For this reason, we recommend always using a Twilio number local to your recipients if you need to receive reply SMS from your end users.

In cases where non-domestic SMS are failing to reach Twilio, the sending party may choose to reach out to the sending carrier to troubleshoot. Please note, however, that receiving non-domestic SMS is not officially supported by Twilio and may not be successful.

Check for roaming off your network

Twilio cannot guarantee the deliverability of SMS from wireless phones that are roaming. If an SMS message is sent to Twilio from a phone number roaming in an area outside of where it normally operates, the message may not arrive.

Twilio does not have the ability to determine whether or not the phone number you are sending SMS from is roaming at the time. In this scenario, we recommend having the sending party escalate to their wireless provider.

Check to see if the SMS is coming from a short code

Twilio accounts can now be enabled to receive messages from short codes. This is an account-wide setting, which will apply to all long code numbers that belong to your Twilio account.

Your account must have a Twilio number from the same country as the short code from which you intend to receive messages. Short code numbers are always country-specific and can only communicate with numbers from the same country.

Please contact Twilio Support to have this option enabled on your account. It is important to note that even when this feature is enabled, we cannot always guarantee delivery of these incoming messages due to factors outside of Twilio's control.

Check if the messages are OTP or 2FA codes

2FA and OTP codes will often be sent from Short Codes. Due to the limitations of these Sender IDs, discussed in the above section, we cannot always guarantee the delivery of these incoming messages.

Please see the section "Check to see if the SMS is coming from a short code" for information on how support can help enable receiving SMS from Short Codes.

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