Issue
During the final steps of configuring Branded Calling, the email verification process may fail. Subsequent retries will result in a displayed error: "Something went wrong. Please try again later."
Product
Programmable Voice
Environment
legacy Twilio Console
Cause
The root cause is currently under investigation.
Resolution
- The current workaround is to start a new Branded Calling setup.
- The previous (old) brand can be deleted.