Issue
Conversations Autocreation allows creating Conversations automatically from incoming messages.
Product
Conversations Classic
Environment
legacy Twilio Console
Cause
If you're not receiving Conversations Messages as expected, there may be an issue with your configuration.
Resolution
- Confirm that you followed the steps detailed here to enable Autocreation in Conversations, whether via Address Configuration API or Twilio Console: Settings for enabling Autocreation in Conversations.
Note that after enabling or disabling Autocreation in the Twilio Console, your changes may take up to 60 seconds to take effect. During these 60 seconds, the previous setting will be in effect.
- Send a test message that you expect to create a new Conversation. Confirm that the Conversation is created and Conversations Message appears under the appropriate Messaging Service.
You can find more details on viewing Conversations via Console, CLI, or API here: How to View All Conversations. - You can track adding of Conversations, Participants, and Messages with the
onParticipantAdded,onParticipantAdded, andonMessageAddedwebhooks: Webhooks on Autocreation. - If Conversation have been autocreated but you're not seeing new incoming messages in a Conversation, please confirm:
- If the number pair is part of the expected Conversation. More details in the API docs here: Conversation Participant resource.
- If the number pair is not a part of the Conversation, incoming messages creates new Conversations.
You can also use this API endpoint to list all the Conversations with a particular number pair binding: Participant Conversation resource.
- If the issue persists, please contact Twilio Support and provide us with some Message Sids and Conversations Sids for further investigation.