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Error "There Was a Problem Attempting to Delete Your Recordings" When Deleting Voice Call Recordings

Issue

When attempting to delete voice call recordings through the Twilio Console, you may encounter an error as shown below:

There was a problem attempting to delete your Recordings.

 

Product

Programable Voice

 

Environment

legacy Twilio Console

 

Cause

One or more of the selected recordings is marked as Absent. Absent recordings contain a Recording SID but do not include an actual audio file. Because there is no underlying media resource, these recordings cannot be deleted through the Console.

 

Resolution

Absent recordings cannot be deleted. When they are included in a delete request, either individually or as part of a bulk selection, the deletion attempt will fail.

To avoid this error:

  1. Identify Absent Recordings: these will appear in the Console with an “Absent” status.
  2. Ensure Absent Recordings Are Not Selected: if you are deleting multiple recordings, do not include any Absent recordings in your selection.
  3. If using “Select All”: the “Select All” checkbox may include Absent recordings on the page.
     

To work around this:

  • Delete recordings in smaller batches (e.g., Select This Page).
  • Verify that the current page does not contain any Absent recordings before deleting.

Once Absent recordings are excluded, the deletion process should complete without error.

Note: If batch deletion through the Console is not feasible due to the total number of recordings, you will need to use the Twilio API to perform the deletions programmatically. Refer to the resources in the Additional Information section below for guidance. 

 

Additional Information 

 

 

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