Issue
When placing outbound calls through Twilio, you may occasionally encounter a situation where calls ring once (or not at all) and are immediately sent to voicemail. This behavior is usually caused by device settings, call-blocking logic, or downstream carrier routing on the destination handset. This article walks you through the most common causes and the steps you can take to diagnose and resolve the issue.
Product
- Programmable Voice
- Elastic SIP Trunking
Causes
- Receiving device settings
- Call blocking software
- Poor caller reputation / carrier-level analytics
Resolution
Cause #1 - Device settings are sending calls to voicemail
If you find that calls to a specific number go to voicemail, but calls to other numbers on the same carrier are reaching the device correctly, this likely indicates a device level issue.
Common mobile device settings that can route calls straight to voicemail include:
- Do Not Disturb
- Silence Unknown Callers (iPhone)
- Block Unknown/Private Numbers (Android)
- Blocked Contacts (This has unknowingly happened to many customers):
- iPhone: Search for Blocked Contacts. Remove the number from the list
- Android: Search for Block numbers. Click Block numbers again and remove the number from the list.
Cause #2 - Third-Party Call Blocking Apps
If device settings are not the cause, there may be an app installed on the device which is filtering the calls to voicemail. Spam-blocking apps can intercept calls before the phone rings. If a call is flagged as spam, the app may silence, block, or divert it to voicemail. Because this happens on the device, carriers and platforms like Twilio usually cannot see or control it. Common spam blocking apps include:
- Hiya
- Truecaller
- RoboKiller
- Nomorobo
- YouMail
- AT&T/Verizon spam apps
Cause #3 - Poor Caller Reputation
If you find that calls to multiple numbers on the same carrier are being diverted to voicemail, there is likely a carrier level block. If a carrier’s analytics provider flags your number as likely spam, telemarketing, or scam, your calls may be soft blocked and sent directly to the callee’s voicemail. You have several options to address this:
-
Twilio Voice Integrity
Signing up for Twilio’s Voice Integrity product can automatically remediate spam labels on your Twilio number. Learn more here. Ready to enroll? Follow the onboarding instructions here. -
Register with Free Caller Registry
Visit https://freecallerregistry.com/fcr/. Registering your number here will notify the three major analytics providers used by AT&T, Verizon, T-Mobile, and others. -
Register Directly with a Carrier’s Analytics Provider
If you know the specific carrier blocking your calls, you can register your number directly with their analytics provider. Here’s a list of some popular U.S. carriers and instructions for removing spam labels from their systems:- AT&T
- AT&T Mobile
- Bandwidth
- Lumen (formerly CenturyLink)
- Comcast
- Frontier Communications, Email: nospam@ftr.com
- Inteliquent
- Sprint
- T-Mobile
- US Cellular
- Verizon
- Verizon Wireless
- Cincinnati Bell - Uses TNS
For more information on how to remove nuisance labels, see this guide: Help Center Article: Outbound Calls Blocked or Labeled as Spam or Scam Likely.