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Unable to Update Number Configuration "There Was an Error"

Issue

When attempting to update a Twilio number's configuration (e.g. When A Call Comes In webhook, When A Message Comes In webhook, Trunk assignment, etc.), after clicking Save configuration the operation fails and you see a message "There was an error".

 

Product

Phone Numbers

 

Cause

This issue can occur when the number is no longer regulatory compliant and missing an approved regulatory bundle necessary to use the number. A number can become non-compliant a number of ways.

  1. A number is purchased before regulatory requirements for the type and country were implemented. This means the number was purchased without an approved / valid regulatory bundle.
  2. The regulatory bundle associated to the number is in a rejected state.
  3. A number is initially compliant, but after regulatory changes, becomes non-compliant and the grace period has expired.

 

Resolution

To resolve this issue, do the following:

  1. Review the regulatory requirements for the country (e.g. UK, Argentina) and type (e.g. mobile, national, landline) of number in our Phone Number Regulations.
  2. If you have an existing regulatory bundle associated with the number that is rejected, correct and update it.
  3. If there is no bundle associated with the number, submit a new regulatory bundle.
  4. Once your bundle is approved, link it to the number to bring the number into compliance.
 

How can I verify the bundle associated with my purchase is correct?

Carefully review the regulatory requirements for the country (e.g. USA, Argentina) and type (e.g. mobile, national, landline) of number in our Phone Number Regulations. For example, you would see failures if you try to use a local bundle to purchase a national number, and the problem would only be resolved after switching to the appropriate national bundle. Do not assume that if the purchase goes through, the bundle is valid. 

 

Additional Information 

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