SUPPORT.TWILIO.COM END OF LIFE NOTICE: This site, support.twilio.com, is scheduled to go End of Life on February 27, 2024. All Twilio Support content has been migrated to help.twilio.com, where you can continue to find helpful Support articles, API docs, and Twilio blog content, and escalate your issues to our Support team. We encourage you to update your bookmarks and begin using the new site today for all your Twilio Support needs.

India Toll Free Voice Number Not Working and Not Receiving Calls

Issue

This article addresses what to do if your Twilio India toll free number is not working (i.e. calls to the number do not connect and you don't hear your configured voice application when calling from one or more numbers).

 

Product

  • Programmable Voice
  • Elastic SIP Trunking
  • Phone Numbers

 

Cause

There are a few potential causes for this issue.

  1. The most common cause is that calls to your India toll free number are coming from outside India (international calls). Toll free numbers can only be reached domestically, meaning your India toll free number can only be called from other India numbers. For example, if you are calling from a +1 US number, there is no way for you to connect with your India toll free number no matter how you dial the number.
  2. Another common cause is the dialing format is incorrect. Your number must be dialed as 000 800 XXX XXXX. Note the +91 country code is not included and there is a 000 prefix before the 800. Again, this still only applies to domestic calls. International calls will not connect no matter the dialing format.
  3. Another potential cause is the voice webhook ("When A Call Comes In" configuration) on your number is either not present, or configured with a webhook that causes failures.
  4. The least common cause, but still possible, is a problem with the number service or in the carrier network routing to the number.

 

Resolution

Here's the step by step to resolve this issue.

  1. First, confirm if the attempted calls show in your Twilio Voice call logs. If attempted calls do not show in your call logs, continue to step 2. If you do see your attempted calls in your call logs, then your number is working normally and there's another issue. See Voice Call Troubleshooting for more details how to troubleshoot calls that do show in your logs.
  2. Second, confirm the number you are calling from is a local / domestic India number (i.e. the calling "from" number, or caller ID, has a +91 country code). If you're trying to call internationally, the call will not connect.
  3. Third, if you're calling from an India number, confirm the dialing format. You should be dialing the number as 000 800 XXX XXXX. You should not include the +91 country code and you must include the 000 prefix.
  4. If you've confirmed the above and the issue still persists, try configuring your number with our demo testing voice URL: http://demo.twilio.com/docs/voice.xml. This demo URL is guaranteed to be functional and will rule out an issue with your existing voice webhook. For instructions how to check the configuration of your number, see How to Configure a Twilio Phone Number to Receive and Respond to Voice Calls.
  5. If you've confirmed all the above and you still do not hear the demo URL message when you try calling your number, then there may be an issue with the number service itself or a carrier related routing issue. In this case, you will need to open a support ticket to have our team investigate further. Please be sure to include all of your test results from the steps above when you open the ticket (i.e. the number you're calling from, exactly how you're dialing the number, and that you tested with the demo voice URL). Including this information from the beginning will help our team resolve your issue faster. To see how to open a support ticket, see Contacting Twilio Support.

Additional Information 

Have more questions? Submit a request
Powered by Zendesk