SUPPORT.TWILIO.COM END OF LIFE NOTICE: This site, support.twilio.com, is scheduled to go End of Life on February 27, 2024. All Twilio Support content has been migrated to help.twilio.com, where you can continue to find helpful Support articles, API docs, and Twilio blog content, and escalate your issues to our Support team. We encourage you to update your bookmarks and begin using the new site today for all your Twilio Support needs.

Unable to Select Studio Flow in Phone Number Configuration

Issue

This article provides guidance on how to manage situations where you need to select an older Twilio Studio Flow through the Twilio Console. The interface currently displays only the 50 most recent Studio Flows, which limits access to older flows that fall outside this range.

 

Product

Twilio Studio

 

Environment

legacy Twilio Console

 

Cause

It is true that older Flows do not appear in the selection list, as the dropdown currently displays only the 50 most recently created Flows.

 

Resolution

There is a workaround that allows you to enter your Flow of choice instead of selecting from the dropdown.

Workaround using Twilio Console

  • Copy your Flow's Webhook URL. The Webhook URL can be found by clicking on the Trigger widget on your Flow Canvas.
  • Load your Twilio number's configuration page.
  • Under A Call/Message comes in, select Webhook
  • Paste your Flow's Webhook URL into the URL field
  • Also paste your Flow's Webhook URL under Call status changes
  • Click Save Configuration at the bottom of the page
  • This will update your Phone number's configuration to direct your calls/messages to your Studio Flow.

 

Workaround using Phone Number REST APIs

  • Copy your Flow's Webhook URL. The Webhook URL can be found by clicking on the Trigger widget on your Flow Canvas.
  • Using IncomingPhoneNumber resource, update SMS/Voice url as shown below:
curl -X POST "https://api.twilio.com/2010-04-01/Accounts/$TWILIO_ACCOUNT_SID/IncomingPhoneNumbers/PNaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.json" \
--data-urlencode "SmsUrl=https://webhooks.twilio.com/v1/Accounts/ACXXXXX/Flows/FWXXXXX" \
--data-urlencode "VoiceUrl=https://webhooks.twilio.com/v1/Accounts/ACXXXXX/Flows/FWXXXXX" \
-u $TWILIO_ACCOUNT_SID:$TWILIO_AUTH_TOKEN
  • This will update your Phone number's configuration to direct your calls/messages to your Studio Flow.

 

Additional Information 

Please reach out our Twilio Customer Support team for any additional questions or requests.
 

Have more questions? Submit a request
Powered by Zendesk