Issue
If an outgoing message to WhatsApp returns a 63016 error code, this means an issue was found with the message you sent. This guide covers topics for diagnosing and resolving the issue.
Please start at the top, and walk through each of the troubleshooting steps as you work your way down the page.
Product
Programmable Messaging
WhatsApp Message Types
WhatsApp divides messages into two different types: Template messages and Session messages.
- Template messages: Outbound messages sent via Twilio that use one of the pre-approved templates. These are generally unsolicited transactional messages (delivery alerts, appointment reminders, etc.) sent to users who have opted in to receive messages from you.
- Session messages: All incoming messages, or outgoing replies to these messages within 24-hours. A messaging session starts when a user sends your application a message, and lasts for 24 hours from the most recently received message. Session messages do not need to follow a template, and can include media attachments.
Any messages sent to a destination that has not responded to you in at least 24-hours will need to be a Template message.
Possible Causes
- WhatsApp templates can only be sent using "Content SID" and "Content Variables" parameters. Templates sent using the "Body" parameter outside of a conversation window will fail with this error.
- This message failed to be delivered to the user because it was sent outside the messaging channel's allowed conversation window. For WhatsApp messages initiated by the business, you must use a pre-defined template.
- If the template was created with Content API or Content Editor it may be one of the following issues:
- You are using the "Body" parameter instead of "Content SID" and "Content Variables" parameters
- You are using a content type that is not supported for business initiated conversations, e.g. listpicker or location
- For Facebook Messenger messages initiated by the business, only publishers registered with the Facebook News Page Index (NPI) are allowed to send notification messages outside the 24-hour window.
Resolution
- Send a WhatsApp message using a template
- Include all the necessary parameters for a Content API or Content Editor Template and make sure you aren't sending with the wrong parameters
- If you are a publisher, register your Facebook Page with the Facebook News Page Index